Attempting next endpoint for pull after error: manifest unknown: OCI manifest found, but accept header does not support OCI manifests
Attempting next endpoint for pull after error: manifest unknown: OCI manifest found, but accept header does not support OCI manifests
podman 构建镜像是发现报 Attempting next endpoint for pull after error: manifest unknown: OCI manifest found, but accept header does not support OCI manifests。 ...
centos7安装高可用k8s集群
centos7安装高可用k8s集群
一、环境准备 1 主机准备 主机 Ip主机名主功能10.200.20.116master01etcd,apiserver,controller-manager,scheduler,docker,proxy10.200.20.117master02etcd,apiserver,controller ...
MacOS docker desktop 替代之 Podman
MacOS docker desktop 替代之 Podman
安装虚拟机 # 本机运行 brew install multipass --cask # 创建一个虚拟机 multipass launch -c 2 -d 20G -m 2G -n podman 20.04 # 启动虚拟机 multipass shell podman 虚拟机运行 sudo ...
执行命令报No such file or directory
执行命令报No such file or directory
更新docker镜像时,执行命令发现报No such file or directory,确定路径是存在的。经过排查发现,没有安装32位兼容库。常见的centos和ubuntu解决方法如下。 # centos yum install xulrunner.i686 yum install libXt ...
docker pull 报错问题总结
docker pull 报错问题总结
存储空间不足 kernel: loop: Write error at byte offset xxxxxxxxxxx, length xxxx. 这种报错是因为拉取的镜像很大,下载或展开镜像时存储空间不足导致的,先腾出空间或者将docker的默认存储位置修改下即可。 # 软连方式 ln -s ...
linux容器 x509: certificate signed by unknown authority
linux容器 x509: certificate signed by unknown authority
在Dockerfile中加入如下命令 # ubuntu RUN set -e; \ export DEBIAN_FRONTEND=noninteractive; \ apt-get update; \ apt-get install -y --no-install-reco ...
docker 单机部署elasticsearch
docker 单机部署elasticsearch
使用docker部署超级简单,已有docker服务的话,只需要简单的两步即可完成elasticsearch部署。 准备环境 docker version: 20.10.8 os version: centos7 elasticsearch version: 7.13.4 准备工作 ...
docker 映射端口无法访问问题
docker 映射端口无法访问问题
卸载老的docker1.3.x版本,重新安装docker-ce 20.x版本,发现映射端口无法访问,容器也无法访问宿主机的网络。简单的几个步骤修复此问题。 准备工作 yum install bridge-utils -y 修复网络 关闭docker systemctl stop do ...
docker 常用命令汇总
docker 常用命令汇总
常用的命令汇总,后续会不端加入新的命令。 Docker 镜像命令 列出镜像列表 $ docker images $ docker image ls -a 运行 Docker 镜像(守护态方式) $ docker run -d {镜像名} 删除指定 Docker 镜像 $ doc ...
k8s证书过期/使用100年证书
k8s证书过期/使用100年证书
常见问题 大概的错误提示:certificate has expired or is not yet valid,生成时间更长的有效期,保证证书不会在短时间失效,如果有必要的话,也可以做相应的监控告警。 单机和集群更新证书,都是在所有master上执行后面的的几个步骤。 如果证书已经过期,可以使 ...
zhr

张文兵

90后程序员

 湖南 - 长沙



友情链接